jQuery masonryはIE7非対応なので・・・

いや~まさか今!この時代に!masonryを使ったグリッドレイアウトでまさかのIE7対応することになるとは!
やっとIEの呪縛から抜け出せてきた今日この頃でしたのに!

しかしクライアント様のサイトのエンドユーザー様様にIE7を使ってらっしゃる方がいるというのならばなんとか対応してあげたいところ。

結論から言うと、別のプラグインを使うべき。

私が乗り換えたのは↓こちら

jquery.vgrid.js
http://blog.xlune.com/2009/09/jqueryvgrid.html

5年も前のプラグインですね。にょろにょろ動くグリッドレイアウトが流行ったのももうそんな昔・・・
しかしここにきてとてもお世話になったので、作者様には感謝です。

 使い方はサイト&demoのソースを見ればOK。
masonryとほぼ同じ。

日本の方が作ったプラグインなので、説明が日本語なのも嬉しポイント。